16.07.2018

NF-e 4.0

 

PROBLEMAS COM PROTOCOLO TLS 1.2 E INCOMPATIBLIDADES NA NF-e 4.00

 

  

Estamos no período de transição da NF-e 3.10 para a 4.00, e muitos desenvolvedores vem enfrentando problemas relacionados à nova versão. Um dos problemas mais recorrentes é referente ao Protocolo TLS 1.2.

 O Protocolo TLS 1.2 passa a ser obrigatório para emissão de NF-e e NFC-e a partir da NF-e 4.00. Conforme descrito na NT 2016.002, o Protocolo SSL foi substituído pelo TLS 1.2 por questões de segurança.

 Os Webservices dos documentos fiscais NF-e, NFC-e, CT-e, CT-e OS e MDF-e não aceitarão mais documentos fiscais emitidos através do Protocolo de Comunicação SSL.

 

Como ativar o Protocolo TLS 1.2 no Windows:

 

- Vá até o Painel de Controle do Windows.

- Escolha a Opção "Opções da Internet"; 

- Vá até a aba “Avançadas”,

- No bloco “Configurações”, vá até as últimas opções;

- Marque: Não salvar páginas criptografadas em disco;

- Marque: Usar SSL 3.0; 

- Desmarque: Usar SSL 2.0; 

- Marque: Usar TLS 1.0; 

- Desmarque: Usar TLS 1.1;

- Marque: Usar TLS 1.2;

- Clique em OK.

 

Além dessas configurações de TLS/SSL, algumas versões Windows não dão suporte ao protocolo TLS 1.2.

 

Veja a lista de Windows que NÃO FUNCIONAM:

 

- Windows Server 2003

- Windows Server 2008

- Windows Server 2008 - SP2 

- Windows Server 2008 - R2 SP1

- Windows 7 - Sem SP1 

- Windows 8

- Windows Vista

- Windows XP

 

Para esses casos, a solução é instalar uma outra versão do sistema operacional.

 

Você ainda pode ter problemas com outras versões do Windows, pois nem todos vem nativamente habilitados para o uso desse protocolo, portanto, será necessário executar o Windows Update para que as atualizações necessárias sejam instalados, e o protocolo seja habilitado.

 

Obs.: Após instalar algumas das atualizações será necessário reiniciar o Windows, lembre-se de sempre que iniciar novamente, abrir o Windows Update novamente e conferir se não apareceram novas atualizações, se houverem, inicie novamente o processo de instalação.

 

Para sistemas construídos em linguagem Java, o TLS 1.2 é suportado apenas pela versão 1.7 ou superior do Java, portanto, caso utilize uma versão anterior a 1.7, o Java deve ser atualizado também.

 

Lembramos ainda que no ambiente de homologação é exigido que o sistema emissor envie a cadeia completa do certificado, conforme descrito nesta nota:

http://www.nfe.go.gov.br/post/ver/182650/obrigatoriedade-de-apresentacao-de-cadeia-de-certificacao-completa

 

IMPORTANTE: Ressaltamos que essas orientações podem não se aplicar a todos os sistemas emissores de documentos fiscais do mercado. É importante sempre contatar o suporte técnico do seu sistema emissor.